Fix Adobe flash player version is not supported

Posted on Tuesday March 05, 2013 by Eric Potvin

By default, when you install flash player video, the hardware abstraction layer is not installed. This might cause issues when you want to play video (for example in Amazon Prime). You will see a message saying flash version isn't supported or Sorry we are unable to stream this video. This is likely because your Flash Player needs to be updated.

The only way you can get around this error is to install this hardware abstraction layer (hal) by using the folloing command:

sudo apt-get install hal

Once the HAL library install is complete, close all Internet browsers and remove the current cache and data:

cd ~/.adobe/Flash_Player
rm -rf NativeCache AssetCache APSPrivateData2

The HAL library cannot play protected content that requires the Adobe Flash Access Digital Rights Management.